summaryrefslogtreecommitdiff
path: root/dbus/Makefile.am
diff options
context:
space:
mode:
authorSimon McVittie <smcv@collabora.com>2018-09-03 14:53:24 -0700
committerSimon McVittie <smcv@collabora.com>2018-12-17 14:12:59 +0000
commit295e5a19a7986ef7f5baca9187f334e83fbf45be (patch)
treeee1c92d5f367ef1b24a3fb61981de9f4efce98b7 /dbus/Makefile.am
parent9c4f9206c494010dffdb4ede26087415f603016b (diff)
downloaddbus-295e5a19a7986ef7f5baca9187f334e83fbf45be.tar.gz
tests: Collect common code from embedded-test main executables
This all seems to have been written by Red Hat or by Collabora, so we have permission to relicense it under the MIT/X11 license, and we might as well do so. Signed-off-by: Simon McVittie <smcv@collabora.com>
Diffstat (limited to 'dbus/Makefile.am')
-rw-r--r--dbus/Makefile.am7
1 files changed, 5 insertions, 2 deletions
diff --git a/dbus/Makefile.am b/dbus/Makefile.am
index f9561bef..3ca6f050 100644
--- a/dbus/Makefile.am
+++ b/dbus/Makefile.am
@@ -266,11 +266,14 @@ DBUS_UTIL_SOURCES= \
dbus-spawn.h \
dbus-string-util.c \
dbus-sysdeps-util.c \
- dbus-test.c \
dbus-test.h
if DBUS_ENABLE_EMBEDDED_TESTS
-DBUS_UTIL_SOURCES += dbus-spawn-test.c
+DBUS_UTIL_SOURCES += \
+ dbus-spawn-test.c \
+ dbus-test-wrappers.c \
+ dbus-test-wrappers.h \
+ $(NULL)
endif
libdbus_1_la_SOURCES= \