summaryrefslogtreecommitdiff
path: root/dbus/Makefile.am
diff options
context:
space:
mode:
authorSimon McVittie <smcv@collabora.com>2017-09-28 13:19:43 +0100
committerRalf Habacker <ralf.habacker@freenet.de>2017-09-28 16:54:36 +0200
commit74b4cc914f33ec9647e960aada686c0680b7e59d (patch)
tree5d2d74261b2a05e8b16d9523b25c502c9378c915 /dbus/Makefile.am
parentc9b86dd3a81b3dd7797d87ba3265087c804a746d (diff)
downloaddbus-74b4cc914f33ec9647e960aada686c0680b7e59d.tar.gz
dbus: Actually link versioninfo.o into libdbus
It appears this has been wrong ever since the versioninfo machinery was first added in 2009, and nobody noticed until now. Bug: https://bugs.freedesktop.org/show_bug.cgi?id=103015 Signed-off-by: Simon McVittie <smcv@collabora.com> Reviewed-by: Philip Withnall <withnall@endlessm.com>
Diffstat (limited to 'dbus/Makefile.am')
-rw-r--r--dbus/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/dbus/Makefile.am b/dbus/Makefile.am
index 064d4152..5ee57ac2 100644
--- a/dbus/Makefile.am
+++ b/dbus/Makefile.am
@@ -310,6 +310,7 @@ libdbus_1_la_LDFLAGS = \
-version-info $(LT_CURRENT):$(LT_REVISION):$(LT_AGE) \
$(SYMBOL_EXPORT_LDFLAGS) \
-no-undefined \
+ $(dbus_res_ldflag) \
$(NULL)
libdbus_internal_la_LIBADD=$(LIBDBUS_LIBS) libdbus-1.la