summaryrefslogtreecommitdiff
path: root/dbus/Makefile.am
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2012-02-02 05:06:25 +0100
committerSimon McVittie <simon.mcvittie@collabora.co.uk>2012-02-07 16:06:33 +0000
commitba71873c7299f9aa58a1e0537ab11831b98ab376 (patch)
tree92706108b476bcaf4c67c6db68ba74ea946b07a5 /dbus/Makefile.am
parent7eca1ce532c9e1af68fb059f29a34ff25a5ac850 (diff)
downloaddbus-ba71873c7299f9aa58a1e0537ab11831b98ab376.tar.gz
at_console: ask systemd whether a user is at the console
systemd manages seats and users. This patch optionally asks systemd whether a user is at the console. It used libsystemd-login for that, a low-level library that allows querying this kind of information without expensive round trips. In order to be nice to the Debian folks this patch falls back to traditional modes of operation if systemd is not found to be around. Bug: https://bugs.freedesktop.org/show_bug.cgi?id=39609 Reviewed-by: Simon McVittie <simon.mcvittie@collabora.co.uk>
Diffstat (limited to 'dbus/Makefile.am')
-rw-r--r--dbus/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/dbus/Makefile.am b/dbus/Makefile.am
index 1c8fe8c8..9ea254e0 100644
--- a/dbus/Makefile.am
+++ b/dbus/Makefile.am
@@ -4,6 +4,7 @@ configdir=$(sysconfdir)/dbus-1
AM_CPPFLAGS = \
-I$(top_builddir) \
-I$(top_srcdir) \
+ $(SYSTEMD_CFLAGS) \
-DDBUS_COMPILATION \
-DDBUS_MACHINE_UUID_FILE=\""$(localstatedir)/lib/dbus/machine-id"\" \
-DDBUS_SYSTEM_CONFIG_FILE=\""$(configdir)/system.conf"\" \
@@ -284,7 +285,7 @@ libdbus_internal_la_CPPFLAGS = \
$(AM_CPPFLAGS) \
-DDBUS_STATIC_BUILD \
$(NULL)
-libdbus_internal_la_LIBADD=$(LIBDBUS_LIBS)
+libdbus_internal_la_LIBADD=$(LIBDBUS_LIBS) $(SYSTEMD_LIBS)
noinst_PROGRAMS =