summaryrefslogtreecommitdiff
path: root/dbus/Makefile.am
diff options
context:
space:
mode:
authorSimon McVittie <simon.mcvittie@collabora.co.uk>2015-02-20 16:14:08 +0000
committerSimon McVittie <simon.mcvittie@collabora.co.uk>2015-02-20 20:50:04 +0000
commitc35d7d1eb773c27018ec4e326bfac0b973e743c0 (patch)
treefde2d3fab110cd15d399808a8bc1272f947a1b47 /dbus/Makefile.am
parent57696a2e8a5eb2df3177f5b52c512a14f3cab1f5 (diff)
downloaddbus-c35d7d1eb773c27018ec4e326bfac0b973e743c0.tar.gz
Fix static linking with mingw
Now that we're normally linking libdbus-1 dynamically, we need to use DBUS_STATIC_BUILD_CPPFLAGS in every Makefile that would normally link it dynamically, but might link it statically if we are only building static libraries. Bug: https://bugs.freedesktop.org/show_bug.cgi?id=83115 Reviewed-by: Ralf Habacker <ralf.habacker@freenet.de>
Diffstat (limited to 'dbus/Makefile.am')
-rw-r--r--dbus/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/dbus/Makefile.am b/dbus/Makefile.am
index 56668d30..e5a5688a 100644
--- a/dbus/Makefile.am
+++ b/dbus/Makefile.am
@@ -4,6 +4,7 @@ configdir=$(sysconfdir)/dbus-1
AM_CPPFLAGS = \
-I$(top_builddir) \
-I$(top_srcdir) \
+ $(DBUS_STATIC_BUILD_CPPFLAGS) \
$(SYSTEMD_CFLAGS) \
$(VALGRIND_CFLAGS) \
-DDBUS_COMPILATION \