summaryrefslogtreecommitdiff
path: root/doc/CMakeLists.txt
diff options
context:
space:
mode:
authorRalf Habacker <ralf.habacker@freenet.de>2019-03-13 10:13:09 +0100
committerRalf Habacker <ralf.habacker@freenet.de>2019-03-13 10:13:09 +0100
commit760e30ec03d21d378890ff87eed91a81f040ba98 (patch)
tree1145e35c95de7266811ae0c56994647558d9bd6a /doc/CMakeLists.txt
parent11eb34d86b513f5ffd4fb0e5cb5f31e6d2f92a49 (diff)
downloaddbus-760e30ec03d21d378890ff87eed91a81f040ba98.tar.gz
Do not let doxygen build man pages on Windows
This fixes an issue on gitlab CI not been able to create man page output dir. Also man pages does not make sense on Windows.
Diffstat (limited to 'doc/CMakeLists.txt')
-rw-r--r--doc/CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/doc/CMakeLists.txt b/doc/CMakeLists.txt
index 25fd7c30..5a5eb85a 100644
--- a/doc/CMakeLists.txt
+++ b/doc/CMakeLists.txt
@@ -12,6 +12,11 @@ endif()
if(DBUS_ENABLE_DOXYGEN_DOCS)
set(top_srcdir ${CMAKE_SOURCE_DIR})
+ if(WIN32)
+ set(DBUS_GENERATE_MAN NO)
+ else()
+ set(DBUS_GENERATE_MAN YES)
+ endif()
configure_file(../Doxyfile.in ${CMAKE_BINARY_DIR}/Doxyfile )
add_custom_command(
OUTPUT ${CMAKE_CURRENT_BINARY_DIR}/api/html/index.html