summaryrefslogtreecommitdiff
path: root/doc/CMakeLists.txt
diff options
context:
space:
mode:
authorRalf Habacker <ralf.habacker@freenet.de>2019-01-24 08:12:19 +0100
committerRalf Habacker <ralf.habacker@freenet.de>2019-01-24 09:07:27 +0100
commit904fa97a1b83217a57bf230f233ccd30d0e44f5b (patch)
tree81ff302bd026e6180d221f880af4a48c5c962f1a /doc/CMakeLists.txt
parent5972bbe382979b08deee398650e406666fe2084c (diff)
downloaddbus-904fa97a1b83217a57bf230f233ccd30d0e44f5b.tar.gz
Remove obsolete parameter in end... cmake keywords
Diffstat (limited to 'doc/CMakeLists.txt')
-rw-r--r--doc/CMakeLists.txt16
1 files changed, 8 insertions, 8 deletions
diff --git a/doc/CMakeLists.txt b/doc/CMakeLists.txt
index 0447f9fb..d87f14ef 100644
--- a/doc/CMakeLists.txt
+++ b/doc/CMakeLists.txt
@@ -8,7 +8,7 @@ add_custom_target(doc ALL)
if(DOXYGEN_EXECUTABLE)
option(DBUS_ENABLE_DOXYGEN_DOCS "build DOXYGEN documentation (requires Doxygen)" ON)
-endif(DOXYGEN_EXECUTABLE)
+endif()
if(DBUS_ENABLE_DOXYGEN_DOCS)
set(top_srcdir ${CMAKE_SOURCE_DIR})
@@ -28,7 +28,7 @@ if(DBUS_ENABLE_DOXYGEN_DOCS)
)
add_dependencies(doc devhelp2)
install(DIRECTORY ${CMAKE_CURRENT_BINARY_DIR}/api/html/ DESTINATION ${CMAKE_INSTALL_DATADIR}/doc/dbus/api)
-endif(DBUS_ENABLE_DOXYGEN_DOCS)
+endif()
find_program(XSLTPROC_EXECUTABLE xsltproc)
if(XSLTPROC_EXECUTABLE)
@@ -89,7 +89,7 @@ macro(DOCBOOK _sources _format)
else()
message(STATUS "skipping xml doc generating for ${_infile}, file not found")
endif()
-endmacro(DOCBOOK)
+endmacro()
### copy tests to builddir so that generated tests and static tests
### are all in one place.
@@ -105,11 +105,11 @@ macro(COPYDIR _src _type)
configure_file(${FILE} ${TARGET} COPYONLY)
if(CONFIG_VERBOSE)
message("FROM: ${FILE}\nTO: ${TARGET}\n")
- endif(CONFIG_VERBOSE)
- endforeach(FILE)
- endforeach(DIR)
- endforeach(FILE_TYPE)
-endmacro(COPYDIR)
+ endif()
+ endforeach()
+ endforeach()
+ endforeach()
+endmacro()
COPYDIR(doc *.png)
COPYDIR(doc *.svg)