summaryrefslogtreecommitdiff
path: root/doc/Makefile.am
diff options
context:
space:
mode:
authorSimon McVittie <simon.mcvittie@collabora.co.uk>2012-11-09 14:24:26 +0000
committerSimon McVittie <simon.mcvittie@collabora.co.uk>2012-11-13 16:13:26 +0000
commit16d0564f30dbe975409e36af5e63ab3ececedda4 (patch)
tree29d9bd132db527bec54efe212e3aadc29c2e501f /doc/Makefile.am
parentb8b3feb98646c8294c86f8391d243aaf3f8ac684 (diff)
downloaddbus-16d0564f30dbe975409e36af5e63ab3ececedda4.tar.gz
Don't include generated documentation in the tarball
Building it unconditionally causes problems for minimal installations (OSTree), and building it opportunistically means the tarball isn't guaranteed to contain it, depending who releases libdbus and which packages they happen to have installed at the time. If this documentation is important enough that we need to ship it precompiled in tarballs, we should guarantee it; or if it isn't important enough to justify that, we should just drop it. I don't think we really need it in the tarballs at all: most users will get their libdbus from a binary distribution (in which case I expect the distribution's dbus maintainers to set appropriate build-dependencies), and those who build from source can either install xmlto, read the documentation on our website, or at worst, read the source XML. (We don't put the Doxygen-generated API reference HTML in the tarball either, and I haven't heard any complaints.) Bug: https://bugs.freedesktop.org/show_bug.cgi?id=55426 Reviewed-by: Colin Walters <walters@verbum.org>
Diffstat (limited to 'doc/Makefile.am')
-rw-r--r--doc/Makefile.am6
1 files changed, 2 insertions, 4 deletions
diff --git a/doc/Makefile.am b/doc/Makefile.am
index db81b5c7..96f7bc38 100644
--- a/doc/Makefile.am
+++ b/doc/Makefile.am
@@ -66,9 +66,7 @@ XMLTO_OUTPUT= \
dbus-tutorial.html
if DBUS_XML_DOCS_ENABLED
-
-# we distribute these in the tarball so users don't necessarily need xmlto
-dist_html_DATA += $(XMLTO_OUTPUT)
+html_DATA += $(XMLTO_OUTPUT)
dbus-specification.html: dbus-specification.xml
$(XMLTO) html-nochunks $<
@@ -132,7 +130,7 @@ BONUS_FILES = \
$(top_srcdir)/COPYING \
$(top_srcdir)/ChangeLog
-dbus-docs: $(STATIC_DOCS) $(dist_doc_DATA) $(dist_html_DATA) $(MAN_HTML_FILES) $(BONUS_FILES) doxygen.stamp
+dbus-docs: $(STATIC_DOCS) $(dist_doc_DATA) $(dist_html_DATA) $(MAN_HTML_FILES) $(BONUS_FILES) doxygen.stamp $(XMLTO_OUTPUT)
$(AM_V_at)rm -rf $@ $@.tmp
$(AM_V_GEN)$(MKDIR_P) $@.tmp/api
$(AM_V_at)cd $(srcdir) && cp $(STATIC_DOCS) @abs_builddir@/$@.tmp