summaryrefslogtreecommitdiff
path: root/doc/Makefile.am
diff options
context:
space:
mode:
authorWill Thompson <will.thompson@collabora.co.uk>2010-09-09 13:15:57 +0100
committerWill Thompson <will.thompson@collabora.co.uk>2010-10-05 11:46:00 +0100
commit783baf9df290a30ee9157338d41a1bfebc36f2ab (patch)
tree08512bf1cfb0d38b064f24d01321867e010b4d55 /doc/Makefile.am
parentee17175118028ad3b2c39be2fd58a21406325b91 (diff)
downloaddbus-783baf9df290a30ee9157338d41a1bfebc36f2ab.tar.gz
Move uploading docs into build system.
This uploads a doc tarball, and its contents, to the appropriate location on dbus.freedesktop.org. It also uploads the DTDs to the appropriate location on specifications.freedesktop.org. I believe this uploads the same files as the old update-dbus-docs.sh script did.
Diffstat (limited to 'doc/Makefile.am')
-rw-r--r--doc/Makefile.am73
1 files changed, 60 insertions, 13 deletions
diff --git a/doc/Makefile.am b/doc/Makefile.am
index ec370843..bc349f87 100644
--- a/doc/Makefile.am
+++ b/doc/Makefile.am
@@ -16,19 +16,25 @@ MAN_HTML_FILES = \
dbus-send.1.html \
dbus-uuidgen.1.html
-EXTRA_DIST= \
- busconfig.dtd \
- diagram.png \
- diagram.svg \
- introspect.dtd \
- dbus-faq.xml \
- dbus-specification.xml \
- dbus-test-plan.xml \
- dbus-tutorial.xml \
- dcop-howto.txt \
- file-boilerplate.c \
- introspect.xsl \
- system-activation.txt \
+DTDS = \
+ busconfig.dtd \
+ introspect.dtd
+
+STATIC_DOCS = \
+ diagram.png \
+ diagram.svg \
+ dbus-faq.xml \
+ dbus-specification.xml \
+ dbus-test-plan.xml \
+ dbus-tutorial.xml \
+ dcop-howto.txt \
+ introspect.xsl \
+ system-activation.txt \
+ $(DTDS)
+
+EXTRA_DIST = \
+ file-boilerplate.c \
+ $(STATIC_DOCS) \
$(MAN_IN_FILES) $(man_MANS)
HTML_FILES= \
@@ -73,8 +79,49 @@ all-local:: $(MAN_HTML_FILES)
$(AM_V_GEN)( $(MAN2HTML) $< > $@.tmp && mv $@.tmp $@ )
endif
+if DBUS_CAN_UPLOAD_DOCS
+BONUS_FILES = \
+ $(top_srcdir)/README \
+ $(top_srcdir)/HACKING \
+ $(top_srcdir)/AUTHORS \
+ $(top_srcdir)/NEWS \
+ $(top_srcdir)/COPYING \
+ $(top_srcdir)/ChangeLog
+
+dbus-docs: $(STATIC_DOCS) $(HTML_FILES) $(MAN_HTML_FILES) $(BONUS_FILES) $(DOXYGEN_HTML_INDEX)
+ $(AM_V_at)rm -rf $@
+ $(AM_V_GEN)mkdir -p $@/api
+ $(AM_V_at)cp $(STATIC_DOCS) $@
+ $(AM_V_at)cp $(HTML_FILES) $@
+ $(AM_V_at)cp $(MAN_HTML_FILES) $@
+ $(AM_V_at)cp $(BONUS_FILES) $@
+ $(AM_V_at)cp -r api/html $@/api
+
+dbus-docs.tar.gz: dbus-docs
+ $(AM_V_GEN)tar czf $@ $<
+
+DOC_SERVER = dbus.freedesktop.org
+DOC_WWW_DIR = /srv/dbus.freedesktop.org/www
+
+SPECIFICATION_SERVER = specifications.freedesktop.org
+SPECIFICATION_PATH = /srv/specifications.freedesktop.org/www/dbus/1.0
+
+maintainer-upload-docs: dbus-docs.tar.gz dbus-docs
+ scp dbus-docs.tar.gz $(DOC_SERVER):$(DOC_WWW_DIR)
+ rsync -rvzP --chmod=Dg+s,ug+rwX,o=rX \
+ dbus-docs/ $(DOC_SERVER):$(DOC_WWW_DIR)/doc/
+ scp -p $(DTDS) $(SPECIFICATION_SERVER):$(SPECIFICATION_PATH)
+else
+maintainer-upload-docs:
+ @echo "Can't upload documentation! Re-run configure with"
+ @echo " --enable-doxygen-docs --enable-xml-docs"
+ @echo "and ensure that man2html is installed."
+ @false
+endif
+
clean-local:
rm -rf api
+ rm -rf dbus-docs
rm -f *.1.html
maintainer-clean-local: