summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorAlex Richardson <arichardson@FreeBSD.org>2022-08-14 16:28:56 +0000
committerSimon McVittie <smcv@collabora.com>2022-09-21 11:35:05 +0000
commit6933a9263e30e2dbfb36a038660b9387ee632d32 (patch)
tree645ee67bafdb5f4283d63157b820c0c2461c83bf /meson.build
parent91f4ac9cf62f8bb99c28ddfa4f376e45fd1b2b94 (diff)
downloaddbus-6933a9263e30e2dbfb36a038660b9387ee632d32.tar.gz
dbus-message.c: skip 1.10 layout compatibility test on new architectures
These static assertions fail on CHERI-enabled architectures such as Arm Morello, where pointers are 128 bits. Architectures with 128-bit pointers were not supported in DBus 1.10, so we can skip the checks for DBus 1.10 structure layout compatibility for architectures with pointer size > 64 bit.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build3
1 files changed, 3 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 9103bb0e..31c6df51 100644
--- a/meson.build
+++ b/meson.build
@@ -276,6 +276,8 @@ foreach type : int_types
endif
endforeach
+arch_config.set('DBUS_SIZEOF_VOID_P', cc.sizeof('void *'))
+
###############################################################################
# Dependencies
@@ -1195,6 +1197,7 @@ summary_dict += {
'64-bit int': arch_config.get('DBUS_INT64_TYPE'),
'32-bit int': arch_config.get('DBUS_INT32_TYPE'),
'16-bit int': arch_config.get('DBUS_INT16_TYPE'),
+ 'pointer size': arch_config.get('DBUS_SIZEOF_VOID_P'),
'xsltproc': xsltproc.found() ? xsltproc.full_path() : '',
'Doxygen': doxygen.found() ? doxygen.full_path() : '',
'ducktype': ducktype.found() ? ducktype.full_path() : '',