summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorIssam E. Maghni <issam.e.maghni@mailbox.org>2021-06-18 21:20:21 -0400
committerSimon McVittie <smcv@collabora.com>2022-10-11 17:14:11 +0100
commit91fe77904acf01b9845c52affdaf49e7b0d2fff7 (patch)
tree9af2696db08643739f9346a5846eb28830c762d1 /meson.build
parente5d8d0c19ad932dad44b3302c90ba692d3a9017a (diff)
downloaddbus-91fe77904acf01b9845c52affdaf49e7b0d2fff7.tar.gz
build: Put system bus socket in runstatedir by default
This lets OS distributors configure --runstatedir=/run if they want to, although for interoperability, they should only do this if they can guarantee that their /run and /var/run are equivalent. A previous commit adds a warning if we are using the default path on a system where /run and /var/run are not synoymous, mitigating the compatibility impact of this change. For CMake, this requires version 3.9, released in 2017. For Meson, this is currently controlled by the runtime_dir option, which defaults to /run if the prefix is /usr. The rationale for this is that /run is correct for modern Unix systems, and distributors who switch from Autotools or CMake to Meson need to review all their build options at that time, which is an ideal opportunity to check that they are doing the right thing around /run. Helps: https://gitlab.freedesktop.org/dbus/dbus/-/issues/180 Co-authored-by: Simon McVittie <smcv@collabora.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build7
1 files changed, 1 insertions, 6 deletions
diff --git a/meson.build b/meson.build
index caaaccf2..33294e2e 100644
--- a/meson.build
+++ b/meson.build
@@ -822,13 +822,8 @@ config.set_quoted('DBUS_SESSION_CONFIG_FILE',
system_socket = get_option('system_socket')
if system_socket == ''
- # We don't use runstatedir for this (yet?), because /var/run has been the
- # interoperable system bus socket for 10+ years.
- # See https://bugs.freedesktop.org/show_bug.cgi?id=101628
system_socket = (
- get_option('prefix')
- / get_option('localstatedir')
- /'run'/'dbus'/'system_bus_socket'
+ get_option('prefix') / runstatedir / 'dbus' / 'system_bus_socket'
)
endif