summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorSimon McVittie <smcv@collabora.com>2022-07-15 12:14:45 +0100
committerSimon McVittie <smcv@collabora.com>2022-07-15 12:22:59 +0100
commite5d2e402f9efec3214f52c51cb91077cefe8698b (patch)
treefc24b5484201de2eca21bee150da4fd11f48c509 /meson.build
parentab01169a2046b8affefb8c984e284a4cd28039d4 (diff)
downloaddbus-e5d2e402f9efec3214f52c51cb91077cefe8698b.tar.gz
meson: Comment why we disable certain compiler warnings
This knowledge shouldn't be lost when we delete the Autotools build system. Signed-off-by: Simon McVittie <smcv@collabora.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build6
1 files changed, 6 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 638bbf5f..cc94bbde 100644
--- a/meson.build
+++ b/meson.build
@@ -1012,8 +1012,14 @@ if cc.get_id() == 'msvc'
]
else
compile_warnings += [
+ # These warnings are intentionally disabled:
+ # - missing field initializers being implicitly 0 is a feature,
+ # not a bug
+ # - -Wunused-parameter is annoying when writing callbacks that follow
+ # a fixed signature but do not necessarily need all of its parameters
'-Wno-missing-field-initializers',
'-Wno-unused-parameter',
+
'-Wchar-subscripts',
'-Wfloat-equal',
]