summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorSimon McVittie <smcv@collabora.com>2022-06-28 12:28:08 +0100
committerSimon McVittie <smcv@collabora.com>2022-07-13 20:36:13 +0100
commitec3edd80a6536d1a8772377e889f5e4cdbeb33e0 (patch)
treee0062ccfd8f05d48a2d543b2c2abb2962e9acfca /meson.build
parent4f966cc1b4431cbb6405cad429b74235c52ad764 (diff)
downloaddbus-ec3edd80a6536d1a8772377e889f5e4cdbeb33e0.tar.gz
meson: Always define HAVE_DECL_MSG_NOSIGNAL to 1 or 0
This is consistent with Autotools AC_CHECK_DECLS. Signed-off-by: Simon McVittie <smcv@collabora.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 2 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index 7a8788ac..2ae2050c 100644
--- a/meson.build
+++ b/meson.build
@@ -618,8 +618,8 @@ config.set('DBUS_VA_COPY', va_copy)
#### Atomic integers
config.set10('DBUS_USE_SYNC', cc.has_function('__sync_sub_and_fetch') ? 1 : false)
-config.set('HAVE_DECL_MSG_NOSIGNAL',
- cc.has_header_symbol('sys/socket.h', 'MSG_NOSIGNAL') ? 1 : false
+config.set10('HAVE_DECL_MSG_NOSIGNAL',
+ cc.has_header_symbol('sys/socket.h', 'MSG_NOSIGNAL')
)
config.set('HAVE_SOCKLEN_T',
cc.has_type('socklen_t', prefix: '#include <sys/socket.h>')