summaryrefslogtreecommitdiff
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
authorRalf Habacker <ralf.habacker@freenet.de>2019-01-24 08:12:19 +0100
committerRalf Habacker <ralf.habacker@freenet.de>2019-01-24 09:07:27 +0100
commit904fa97a1b83217a57bf230f233ccd30d0e44f5b (patch)
tree81ff302bd026e6180d221f880af4a48c5c962f1a /test/CMakeLists.txt
parent5972bbe382979b08deee398650e406666fe2084c (diff)
downloaddbus-904fa97a1b83217a57bf230f233ccd30d0e44f5b.tar.gz
Remove obsolete parameter in end... cmake keywords
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt18
1 files changed, 9 insertions, 9 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
index bd24d61a..2b348a4f 100644
--- a/test/CMakeLists.txt
+++ b/test/CMakeLists.txt
@@ -211,7 +211,7 @@ set(CONFIG_VERBOSE 1)
foreach(DIR ${TESTDIRS})
file(MAKE_DIRECTORY ${CMAKE_BINARY_DIR}/${DIR})
-endforeach(DIR)
+endforeach()
### copy tests to builddir so that generated tests and static tests
### are all in one place.
@@ -225,10 +225,10 @@ foreach(FILE_TYPE *.message-raw *.auth-script *.sha1 *.txt *.conf *.service)
configure_file(${FILE} ${TARGET} COPYONLY)
if(CONFIG_VERBOSE)
message("${FILE}")
- endif(CONFIG_VERBOSE)
- endforeach(FILE)
- endforeach(DIR)
-endforeach(FILE_TYPE)
+ endif()
+ endforeach()
+ endforeach()
+endforeach()
### generate test files
message(STATUS "Generating test files from templates into test directory")
@@ -243,10 +243,10 @@ foreach(FILE_TYPE *.conf.in *.service.in)
configure_file(${FILE} ${TARGET} @ONLY IMMEDIATE)
if(CONFIG_VERBOSE)
message("${FILE}")
- endif(CONFIG_VERBOSE)
- endforeach(FILE)
- endforeach(DIR)
-endforeach(FILE_TYPE)
+ endif()
+ endforeach()
+ endforeach()
+endforeach()
message(STATUS "Copying generated bus config files to test directory")
configure_file(../bus/session.conf.in ${CMAKE_BINARY_DIR}/test/data/valid-config-files/session.conf @ONLY)