summaryrefslogtreecommitdiff
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
authorSimon McVittie <smcv@collabora.com>2020-04-16 14:21:36 +0100
committerSimon McVittie <smcv@collabora.com>2020-04-20 10:13:07 +0100
commite559663e038cc48aa7120cd6f3d4ed52a4e9abca (patch)
treede5ca8f3aaa3f8b4b02b2c4d563ff8bfe7b7cfc5 /test/CMakeLists.txt
parentc383f151be876461a5bfc4d307a2a76c78bcc5cd (diff)
downloaddbus-e559663e038cc48aa7120cd6f3d4ed52a4e9abca.tar.gz
test: Replace _dbus_assert_not_reached()
Assertions can be disabled; but in test code the assertions are the entire point, so we don't want to disable them. Use _dbus_test_fatal() instead. test-service is actually a test helper rather than a test, so use its pre-existing die() function instead. Signed-off-by: Simon McVittie <smcv@collabora.com>
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
index d0cc8d4d..f78bba54 100644
--- a/test/CMakeLists.txt
+++ b/test/CMakeLists.txt
@@ -92,7 +92,7 @@ add_helper_executable(test-sleep-forever ${test-sleep-forever_SOURCES} ${DBUS_IN
add_helper_executable(manual-tcp ${manual-tcp_SOURCES} ${DBUS_INTERNAL_LIBRARIES})
add_helper_executable(manual-backtrace manual-backtrace.c dbus-1)
if(WIN32)
- add_helper_executable(manual-paths ${manual-paths_SOURCES} ${DBUS_INTERNAL_LIBRARIES})
+ add_helper_executable(manual-paths ${manual-paths_SOURCES} dbus-testutils)
endif()
if(DBUS_ENABLE_EMBEDDED_TESTS)