summaryrefslogtreecommitdiff
path: root/test/Makefile.am
diff options
context:
space:
mode:
authorSimon McVittie <smcv@collabora.com>2018-10-31 15:09:24 +0000
committerSimon McVittie <smcv@collabora.com>2018-10-31 16:56:36 +0000
commit168bbe146c301d4ca515d8e8ac57c1eda2fa06c7 (patch)
treee5013d8f92d53bb096b7f25b95cd234a98262a91 /test/Makefile.am
parent06b8055690f2f832e290eb476e5759b6bf2d3e52 (diff)
downloaddbus-168bbe146c301d4ca515d8e8ac57c1eda2fa06c7.tar.gz
tests: Build installable helpers whenever any tests are enabled
We might need these to run tests at build-time, so we should build them whenever either modular or embedded tests are enabled, even if installed-tests aren't. We haven't noticed this bug until now because $(installable_helpers) only contained test-apparmor-activation, which isn't normally needed at build-time because the AppArmor test can only work when run as root. Signed-off-by: Simon McVittie <smcv@collabora.com>
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am12
1 files changed, 10 insertions, 2 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index 399c3370..539acb6c 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -424,10 +424,18 @@ if DBUS_ENABLE_INSTALLED_TESTS
nobase_testmeta_DATA += $(installable_test_meta)
nobase_testmeta_DATA += $(installable_test_meta_with_config)
else !DBUS_ENABLE_INSTALLED_TESTS
- noinst_PROGRAMS += $(installable_tests) $(installable_manual_tests)
+ noinst_PROGRAMS += $(installable_helpers)
+ noinst_PROGRAMS += $(installable_manual_tests)
+ noinst_PROGRAMS += $(installable_tests)
endif !DBUS_ENABLE_INSTALLED_TESTS
-endif DBUS_ENABLE_MODULAR_TESTS
+else !DBUS_ENABLE_MODULAR_TESTS
+
+if DBUS_ENABLE_EMBEDDED_TESTS
+ noinst_PROGRAMS += $(installable_helpers)
+endif DBUS_ENABLE_EMBEDDED_TESTS
+
+endif !DBUS_ENABLE_MODULAR_TESTS
# If we're installing the tests into a DESTDIR we can't run them
# again using the installed copy, because we don't know how to