summaryrefslogtreecommitdiff
path: root/test/Makefile.am
diff options
context:
space:
mode:
authorSimon McVittie <smcv@collabora.com>2018-09-03 16:57:10 -0700
committerSimon McVittie <smcv@collabora.com>2019-01-21 15:17:36 +0000
commit3b512610c0414c4f40c464e1a8dd5d3d665e74d7 (patch)
tree22c89e2f4b4c53452e8407362eb15ef680599b9c /test/Makefile.am
parenta15839da9b4575a8f9c433c5afed85b02a044162 (diff)
downloaddbus-3b512610c0414c4f40c464e1a8dd5d3d665e74d7.tar.gz
test: Break out the slow parts of test-bus into their own executables
This makes it more convenient to re-run the rest of test-bus as required when debugging. Signed-off-by: Simon McVittie <smcv@collabora.com>
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am12
1 files changed, 11 insertions, 1 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index 5d34f2be..475fb214 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -79,7 +79,11 @@ if !DBUS_WINCE
uninstallable_test_programs += test-spawn-oom
endif
-uninstallable_test_programs += test-bus
+uninstallable_test_programs += \
+ test-bus \
+ test-bus-dispatch \
+ test-bus-dispatch-sha1 \
+ $(NULL)
if DBUS_UNIX
uninstallable_test_programs += test-bus-launch-helper-oom
@@ -168,6 +172,12 @@ test_bus_system_LDADD = $(top_builddir)/bus/liblaunch-helper-internal.la
test_bus_SOURCES = bus/main.c
test_bus_LDADD = $(top_builddir)/bus/libdbus-daemon-internal.la
+test_bus_dispatch_SOURCES = bus/dispatch.c
+test_bus_dispatch_LDADD = $(top_builddir)/bus/libdbus-daemon-internal.la
+
+test_bus_dispatch_sha1_SOURCES = bus/dispatch-sha1.c
+test_bus_dispatch_sha1_LDADD = $(top_builddir)/bus/libdbus-daemon-internal.la
+
EXTRA_DIST += dbus-test-runner
testexecdir = $(libexecdir)/installed-tests/dbus