summaryrefslogtreecommitdiff
path: root/test/Makefile.am
diff options
context:
space:
mode:
authorSimon McVittie <smcv@collabora.com>2018-10-18 13:45:12 +0100
committerSimon McVittie <smcv@collabora.com>2018-10-19 11:11:55 +0000
commit5defe7d9eb066d5d3fa73123b389dc12009ee713 (patch)
treeea0eec1e6aefdb5d831d57b11f679bcab8437f73 /test/Makefile.am
parent91de178f9e00d0136f288cf2179bb0cde5f04af0 (diff)
downloaddbus-5defe7d9eb066d5d3fa73123b389dc12009ee713.tar.gz
Add basic test coverage for the bus' desktop file parser
This doesn't cover backslash-escaping in values, or various other corner cases, but it's a start. Signed-off-by: Simon McVittie <smcv@collabora.com>
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am10
1 files changed, 10 insertions, 0 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index 7e2e202f..399c3370 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -161,6 +161,7 @@ installable_tests += \
test-corrupt \
test-dbus-daemon \
test-dbus-daemon-eavesdrop \
+ test-desktop-file \
test-fdpass \
test-header-fields \
test-message \
@@ -327,6 +328,15 @@ test_dbus_daemon_eavesdrop_LDADD = \
$(GLIB_LIBS) \
$(NULL)
+test_desktop_file_SOURCES = \
+ internals/desktop-file.c \
+ $(NULL)
+test_desktop_file_LDADD = \
+ libdbus-testutils.la \
+ $(top_builddir)/dbus/libdbus-internal.la \
+ $(GLIB_LIBS) \
+ $(NULL)
+
test_header_fields_SOURCES = \
header-fields.c \
$(NULL)