summaryrefslogtreecommitdiff
path: root/test/Makefile.am
diff options
context:
space:
mode:
authorSimon McVittie <smcv@collabora.com>2018-12-03 16:04:56 +0000
committerSimon McVittie <smcv@collabora.com>2018-12-11 12:47:22 +0000
commit64f94d3f5bc4e1229abc5a9ec7ae089b3b259719 (patch)
tree08b6e3007bafb63660d2c78300d7f7121d26334f /test/Makefile.am
parentc3d15a9eade40627a8ea5ded95068c6d2294cdf5 (diff)
downloaddbus-64f94d3f5bc4e1229abc5a9ec7ae089b3b259719.tar.gz
Move _dbus_disable_crash_handling() back into test/ directory
It's only used in test code. We have to put it in its own translation unit with no non-libc dependencies so that we can compile a copy of it without AddressSanitizer support, because in a subsequent commit we will special-case test-segfault to be compiled without using AddressSanitizer, which would make linking to an AddressSanitizer-instrumented libdbus fail. Signed-off-by: Simon McVittie <smcv@collabora.com>
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am12
1 files changed, 10 insertions, 2 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index baec9639..2f649837 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -28,6 +28,8 @@ AM_CFLAGS = \
noinst_LTLIBRARIES = libdbus-testutils.la
libdbus_testutils_la_SOURCES = \
+ disable-crash-handling.c \
+ disable-crash-handling.h \
test-utils.c \
test-utils.h \
$(NULL)
@@ -107,8 +109,14 @@ test_printf_LDADD = $(top_builddir)/dbus/libdbus-internal.la
test_refs_SOURCES = internals/refs.c
test_refs_LDADD = libdbus-testutils.la $(GLIB_LIBS)
-test_segfault_SOURCES = test-segfault.c
-test_segfault_LDADD = $(top_builddir)/dbus/libdbus-internal.la
+# We have to compile a separate copy of disable-crash-handling.c for
+# test-segfault rather than using libdbus-testutils.la, because
+# otherwise it would fail to link when using the AddressSanitizer.
+test_segfault_SOURCES = \
+ disable-crash-handling.c \
+ disable-crash-handling.h \
+ test-segfault.c \
+ $(NULL)
test_server_oom_SOURCES = internals/server-oom.c
test_server_oom_LDADD = libdbus-testutils.la $(GLIB_LIBS)