summaryrefslogtreecommitdiff
path: root/test/Makefile.am
diff options
context:
space:
mode:
authorSimon McVittie <smcv@collabora.com>2018-09-28 16:36:49 +0100
committerSimon McVittie <smcv@collabora.com>2019-01-21 15:21:16 +0000
commit8ead2011ac29fc8678c0ed2bf0483a40899dbc04 (patch)
treea977705d38e3e8545acc1c2d25b93dfcf038c719 /test/Makefile.am
parent5424eb2b0d93fb60cee658e1f9198f43dfd15ec7 (diff)
downloaddbus-8ead2011ac29fc8678c0ed2bf0483a40899dbc04.tar.gz
test: Move marshalling tests into test/
dbus-marshal-recursive-util.c contains utility functions used by the other two, as well as tests. The others are purely test code. Signed-off-by: Simon McVittie <smcv@collabora.com>
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am12
1 files changed, 11 insertions, 1 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index a150e2b9..2c8bc895 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -203,10 +203,16 @@ test_bus_dispatch_sha1_LDADD = \
test_hash_SOURCES = internals/hash.c
test_hash_LDADD = libdbus-testutils.la
-test_marshal_recursive_SOURCES = internals/marshal-recursive.c
+test_marshal_recursive_SOURCES = \
+ internals/dbus-marshal-recursive-util.c \
+ internals/dbus-marshal-recursive-util.h \
+ internals/marshal-recursive.c \
+ $(NULL)
test_marshal_recursive_LDADD = libdbus-testutils.la
test_message_internals_SOURCES = \
+ internals/dbus-marshal-recursive-util.c \
+ internals/dbus-marshal-recursive-util.h \
internals/dbus-message-factory.c \
internals/dbus-message-factory.h \
internals/dbus-message-util.c \
@@ -220,6 +226,10 @@ test_misc_internals_SOURCES = \
internals/dbus-auth-script.h \
internals/dbus-auth-util.c \
internals/dbus-credentials-util.c \
+ internals/dbus-marshal-byteswap-util.c \
+ internals/dbus-marshal-recursive-util.c \
+ internals/dbus-marshal-recursive-util.h \
+ internals/dbus-marshal-validate-util.c \
internals/misc-internals.c \
internals/misc-internals.h \
$(NULL)