summaryrefslogtreecommitdiff
path: root/test/Makefile.am
diff options
context:
space:
mode:
authorSimon McVittie <smcv@collabora.com>2018-10-31 15:21:12 +0000
committerSimon McVittie <smcv@collabora.com>2018-10-31 16:56:36 +0000
commit93c1d08300605893cb1c6645bead1b1654378c56 (patch)
treec56870f7f0768b20b4ba2dfff23b7a68d4da13a0 /test/Makefile.am
parent6eb1c2cd53d6f38f769964b3e4f509a4ef957ab3 (diff)
downloaddbus-93c1d08300605893cb1c6645bead1b1654378c56.tar.gz
tests: Add a unit test for _dbus_command_for_pid()
In particular this demonstrates that dbus#222 has been solved. Signed-off-by: Simon McVittie <smcv@collabora.com>
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index 5f99b689..e439bfe4 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -108,6 +108,9 @@ test_refs_LDADD = libdbus-testutils.la $(GLIB_LIBS)
test_server_oom_SOURCES = internals/server-oom.c
test_server_oom_LDADD = libdbus-testutils.la $(GLIB_LIBS)
+test_sysdeps_SOURCES = internals/sysdeps.c
+test_sysdeps_LDADD = libdbus-testutils.la $(GLIB_LIBS)
+
test_syslog_SOURCES = internals/syslog.c
test_syslog_LDADD = libdbus-testutils.la $(GLIB_LIBS)
@@ -172,6 +175,7 @@ installable_tests += \
test-relay \
test-server-oom \
test-syntax \
+ test-sysdeps \
test-syslog \
test-uid-permissions \
test-variant \