summaryrefslogtreecommitdiff
path: root/test/Makefile.am
diff options
context:
space:
mode:
authorSimon McVittie <smcv@collabora.com>2018-12-11 11:52:38 +0000
committerSimon McVittie <smcv@collabora.com>2018-12-13 13:08:00 +0000
commit9490e954d0cce75f5c1aad10b6b3c67f5c4a082e (patch)
tree4726f16d4719fb0a9a52706c614a808387f0ab8a /test/Makefile.am
parent0d79fa68c066e5b38b310be3066d22c813561d43 (diff)
downloaddbus-9490e954d0cce75f5c1aad10b6b3c67f5c4a082e.tar.gz
test-privserver: Move helper executable out of name-test/
This means we don't need to distinguish between DBUS_NAME_TEST_EXEC and DBUS_TEST_EXEC any more, because all test helper executables are in the same place, both during build and when installed (we don't install test-privserver since no installed test requires it yet, but in principle we could). Signed-off-by: Simon McVittie <smcv@collabora.com>
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index b8df15ac..1e7c2db4 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -66,6 +66,7 @@ TEST_BINARIES = \
test-spawn \
test-exit \
test-names \
+ test-privserver \
test-segfault \
test-shell-service \
$(NULL)
@@ -100,6 +101,7 @@ test_segfault_CFLAGS =
test_service_LDADD = libdbus-testutils.la
test_names_LDADD = libdbus-testutils.la
+test_privserver_LDADD = libdbus-testutils.la
## break_loader_LDADD = $(top_builddir)/dbus/libdbus-internal.la
test_shell_service_LDADD = libdbus-testutils.la
test_shell_SOURCES = shell-test.c
@@ -626,7 +628,6 @@ uninstalled-config-local:
sed \
-e 's,[@]DBUS_SESSION_CONF_MAYBE_AUTH_EXTERNAL[@],$(DBUS_SESSION_CONF_MAYBE_AUTH_EXTERNAL),' \
-e 's,[@]DBUS_SESSION_BUS_LISTEN_ADDRESS[@],$(DBUS_SESSION_BUS_LISTEN_ADDRESS),' \
- -e 's,[@]DBUS_NAME_TEST_EXEC[@],$(DBUS_NAME_TEST_EXEC),' \
-e 's,[@]DBUS_TEST_DATA[@],@abs_builddir@/data,' \
-e 's,[@]DBUS_TEST_EXEC[@],@abs_builddir@,' \
-e 's,[@]DBUS_USER[@],$(DBUS_USER),' \
@@ -644,7 +645,6 @@ if DBUS_ENABLE_INSTALLED_TESTS
sed \
-e 's,[@]DBUS_SESSION_CONF_MAYBE_AUTH_EXTERNAL[@],$(DBUS_SESSION_CONF_MAYBE_AUTH_EXTERNAL),' \
-e 's,[@]DBUS_SESSION_BUS_LISTEN_ADDRESS[@],$(DBUS_SESSION_BUS_LISTEN_ADDRESS),' \
- -e 's,[@]DBUS_NAME_TEST_EXEC[@],$(DBUS_NAME_TEST_EXEC),' \
-e 's,[@]DBUS_TEST_DATA[@],$(testexecdir)/data,' \
-e 's,[@]DBUS_TEST_EXEC[@],$(testexecdir),' \
-e 's,[@]DBUS_USER[@],$(DBUS_USER),' \