summaryrefslogtreecommitdiff
path: root/test/Makefile.am
diff options
context:
space:
mode:
authorSimon McVittie <smcv@collabora.com>2018-09-28 16:27:42 +0100
committerSimon McVittie <smcv@collabora.com>2019-01-21 15:20:22 +0000
commit9feeeaea9a9afb9bb8aa2a2d4eefb3e909026674 (patch)
tree253ca13d73f5237e6cd1af4a70fcc08aec1c4cd3 /test/Makefile.am
parentb4b0e1b3f57341b140f6542b98ded8b13d35706d (diff)
downloaddbus-9feeeaea9a9afb9bb8aa2a2d4eefb3e909026674.tar.gz
test: Move auth, credentials tests from libdbus-internal into test/
Signed-off-by: Simon McVittie <smcv@collabora.com>
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am9
1 files changed, 8 insertions, 1 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index 58e72559..451655b3 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -209,7 +209,14 @@ test_marshal_recursive_LDADD = libdbus-testutils.la
test_message_internals_SOURCES = internals/message-internals.c
test_message_internals_LDADD = libdbus-testutils.la
-test_misc_internals_SOURCES = internals/misc-internals.c
+test_misc_internals_SOURCES = \
+ internals/dbus-auth-script.c \
+ internals/dbus-auth-script.h \
+ internals/dbus-auth-util.c \
+ internals/dbus-credentials-util.c \
+ internals/misc-internals.c \
+ internals/misc-internals.h \
+ $(NULL)
test_misc_internals_LDADD = libdbus-testutils.la
EXTRA_DIST += dbus-test-runner