summaryrefslogtreecommitdiff
path: root/test/Makefile.am
diff options
context:
space:
mode:
authorSimon McVittie <smcv@collabora.com>2018-11-15 14:08:03 +0000
committerSimon McVittie <smcv@collabora.com>2019-01-21 15:19:36 +0000
commitb7f11c17d15fabebf216445be58afd0e321fc1b9 (patch)
treef50185356f49af28bdf7a776e49532e96267c5d3 /test/Makefile.am
parente23bba929a54a4fa3b140e7240955d8121942a5d (diff)
downloaddbus-b7f11c17d15fabebf216445be58afd0e321fc1b9.tar.gz
_dbus_test_main: Move to test-utils
Now that there is no code outside test/ that calls into this, we can move it into test/, reducing the size of libdbus. dbus-test-tap.[ch] still need to stay in dbus/ as long as there is code in dbus/ or bus/ relying on them, and also need to be linked into libdbus as long as there is other code in libdbus relying on them, so they stay where they are for now. Similarly, dbus-tests.h lists the tests that are still embedded in libdbus, and must stay where it is for the moment. With this move, various tests now need to be linked to the dbus-testutils convenience library. Signed-off-by: Simon McVittie <smcv@collabora.com>
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am29
1 files changed, 22 insertions, 7 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index 02797721..eecfec85 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -120,7 +120,7 @@ test_shell_LDADD = libdbus-testutils.la
test_spawn_SOURCES = spawn-test.c
test_spawn_LDADD = $(top_builddir)/dbus/libdbus-internal.la
test_spawn_oom_SOURCES = internals/spawn-oom.c
-test_spawn_oom_LDADD = $(top_builddir)/dbus/libdbus-internal.la
+test_spawn_oom_LDADD = libdbus-testutils.la
test_assertions_SOURCES = internals/assertions.c
test_assertions_LDADD = libdbus-testutils.la $(GLIB_LIBS)
@@ -165,25 +165,40 @@ manual_tcp_SOURCES = manual-tcp.c
manual_tcp_LDADD = $(top_builddir)/dbus/libdbus-internal.la
test_bus_launch_helper_oom_SOURCES = bus/launch-helper-oom.c
-test_bus_launch_helper_oom_LDADD = $(top_builddir)/bus/liblaunch-helper-internal.la
+test_bus_launch_helper_oom_LDADD = \
+ $(top_builddir)/bus/liblaunch-helper-internal.la \
+ libdbus-testutils.la \
+ $(NULL)
dbus_daemon_launch_helper_for_tests_SOURCES = bus/launch-helper-for-tests.c
dbus_daemon_launch_helper_for_tests_LDADD = $(top_builddir)/bus/liblaunch-helper-internal.la
test_bus_system_SOURCES = bus/system.c
-test_bus_system_LDADD = $(top_builddir)/bus/liblaunch-helper-internal.la
+test_bus_system_LDADD = \
+ $(top_builddir)/bus/liblaunch-helper-internal.la \
+ libdbus-testutils.la \
+ $(NULL)
test_bus_SOURCES = bus/main.c
-test_bus_LDADD = $(top_builddir)/bus/libdbus-daemon-internal.la
+test_bus_LDADD = \
+ $(top_builddir)/bus/libdbus-daemon-internal.la \
+ libdbus-testutils.la \
+ $(NULL)
test_bus_dispatch_SOURCES = bus/dispatch.c
-test_bus_dispatch_LDADD = $(top_builddir)/bus/libdbus-daemon-internal.la
+test_bus_dispatch_LDADD = \
+ $(top_builddir)/bus/libdbus-daemon-internal.la \
+ libdbus-testutils.la \
+ $(NULL)
test_bus_dispatch_sha1_SOURCES = bus/dispatch-sha1.c
-test_bus_dispatch_sha1_LDADD = $(top_builddir)/bus/libdbus-daemon-internal.la
+test_bus_dispatch_sha1_LDADD = \
+ $(top_builddir)/bus/libdbus-daemon-internal.la \
+ libdbus-testutils.la \
+ $(NULL)
test_misc_internals_SOURCES = internals/misc-internals.c
-test_misc_internals_LDADD = $(top_builddir)/dbus/libdbus-internal.la
+test_misc_internals_LDADD = libdbus-testutils.la
EXTRA_DIST += dbus-test-runner