summaryrefslogtreecommitdiff
path: root/test/Makefile.am
diff options
context:
space:
mode:
authorSimon McVittie <smcv@collabora.com>2020-04-16 14:21:36 +0100
committerSimon McVittie <smcv@collabora.com>2020-04-20 10:13:07 +0100
commite559663e038cc48aa7120cd6f3d4ed52a4e9abca (patch)
treede5ca8f3aaa3f8b4b02b2c4d563ff8bfe7b7cfc5 /test/Makefile.am
parentc383f151be876461a5bfc4d307a2a76c78bcc5cd (diff)
downloaddbus-e559663e038cc48aa7120cd6f3d4ed52a4e9abca.tar.gz
test: Replace _dbus_assert_not_reached()
Assertions can be disabled; but in test code the assertions are the entire point, so we don't want to disable them. Use _dbus_test_fatal() instead. test-service is actually a test helper rather than a test, so use its pre-existing die() function instead. Signed-off-by: Simon McVittie <smcv@collabora.com>
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index a992bf91..b539524c 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -175,7 +175,7 @@ manual_dir_iter_SOURCES = manual-dir-iter.c
manual_dir_iter_LDADD = $(top_builddir)/dbus/libdbus-internal.la
manual_paths_SOURCES = manual-paths.c
-manual_paths_LDADD = $(top_builddir)/dbus/libdbus-internal.la
+manual_paths_LDADD = libdbus-testutils.la
manual_tcp_SOURCES = manual-tcp.c
manual_tcp_LDADD = $(top_builddir)/dbus/libdbus-internal.la