summaryrefslogtreecommitdiff
path: root/test/meson.build
diff options
context:
space:
mode:
authorRalf Habacker <ralf.habacker@freenet.de>2023-01-03 14:21:51 +0100
committerRalf Habacker <ralf.habacker@freenet.de>2023-01-05 16:43:55 +0100
commit20febb522b3dd0b932244e48f50d2fcbb98c3b4f (patch)
tree6db703d564d594134c4333911ace199e61ed52f7 /test/meson.build
parent255f103b5cf2710cd9e7eddb4d289201a2ccaa12 (diff)
downloaddbus-20febb522b3dd0b932244e48f50d2fcbb98c3b4f.tar.gz
Add multithreaded unit test for DBusCounter to available build systems
The mentioned test is build on unix like platforms when embedded tests are enabled.
Diffstat (limited to 'test/meson.build')
-rw-r--r--test/meson.build10
1 files changed, 10 insertions, 0 deletions
diff --git a/test/meson.build b/test/meson.build
index 966e8ab7..23ad6b0a 100644
--- a/test/meson.build
+++ b/test/meson.build
@@ -298,6 +298,16 @@ if embedded_tests
]
endif
+ if platform_unix
+ tests += [
+ {
+ 'name': 'counter',
+ 'srcs': [ 'internals/counter.c' ],
+ 'link': [ libdbus_testutils, ],
+ },
+ ]
+ endif
+
if use_traditional_activation and platform_unix
tests += [
{