summaryrefslogtreecommitdiff
path: root/test/meson.build
diff options
context:
space:
mode:
authorSimon McVittie <smcv@collabora.com>2022-06-23 19:27:05 +0100
committerSimon McVittie <smcv@collabora.com>2022-07-13 20:36:13 +0100
commit22b12cdb3fecb548fb9d5d509abb2a65afd6fab1 (patch)
treef22af86a49f8580ff53c9698698ad316ff49b0bc /test/meson.build
parent4bce2c36f0f65b29a182432f49653dd1ac150708 (diff)
downloaddbus-22b12cdb3fecb548fb9d5d509abb2a65afd6fab1.tar.gz
test: Disable sanitizers for test-segfault
This resolves the TODO comment. Signed-off-by: Simon McVittie <smcv@collabora.com>
Diffstat (limited to 'test/meson.build')
-rw-r--r--test/meson.build5
1 files changed, 2 insertions, 3 deletions
diff --git a/test/meson.build b/test/meson.build
index 22855857..e1d14fec 100644
--- a/test/meson.build
+++ b/test/meson.build
@@ -133,13 +133,12 @@ test_privserver = executable('test-privserver',
)
# This helper is meant to crash, so if we're compiling the rest with
# AddressSanitizer, we need to stop it from catching the SIGSEGV and
-# turning it into _exit(1); so don't give it SANITIZE_CFLAGS.
-# CODE_COVERAGE_CFLAGS are fairly pointless here, too.
-# TODO
+# turning it into _exit(1).
test_segfault = executable('test-segfault',
'test-segfault.c', 'disable-crash-handling.c',
include_directories: root_include,
dependencies: dbus_dependencies,
+ override_options: ['b_sanitize=none'],
)
test_shell_service = executable('test-shell-service',
'test-shell-service.c',