summaryrefslogtreecommitdiff
path: root/test/meson.build
diff options
context:
space:
mode:
authorSimon McVittie <smcv@collabora.com>2022-07-15 01:37:47 +0100
committerSimon McVittie <smcv@collabora.com>2022-07-15 10:10:54 +0100
commit57e21c03581378256495e9824773c6f20c6197cc (patch)
tree11e6e254582b76001e169812e99b4562ef713641 /test/meson.build
parent2d3f48e8c85bd884888da4e62e2ae0a195e22e69 (diff)
downloaddbus-57e21c03581378256495e9824773c6f20c6197cc.tar.gz
test: Work around TAP test regression in Meson 0.63.0
With Meson 0.63.0, detailed output of TAP tests is not logged, and the test deadlocks if the stderr pipe fills up. I'm hoping this will be fixed before 0.63.1, but in the meantime we can work around it by falling back to the 'exitcode' protocol: this means we lose machine-readable detailed test results, but at least our tests pass. See https://github.com/mesonbuild/meson/issues/10577 and https://github.com/mesonbuild/meson/issues/10563 for details of the Meson regression. Signed-off-by: Simon McVittie <smcv@collabora.com>
Diffstat (limited to 'test/meson.build')
-rw-r--r--test/meson.build9
1 files changed, 8 insertions, 1 deletions
diff --git a/test/meson.build b/test/meson.build
index e6360900..e310e9db 100644
--- a/test/meson.build
+++ b/test/meson.build
@@ -101,6 +101,13 @@ xdgdir = custom_target('gen-xdgdir',
installed_tests = []
+if meson.version().version_compare('>=0.63')
+ # Work around https://github.com/mesonbuild/meson/issues/10577
+ test_protocol = 'exitcode'
+else
+ test_protocol = 'tap'
+endif
+
###############################################################################
# Dbus testutils
@@ -575,7 +582,7 @@ foreach test: tests
test_exe,
args: ['--tap'],
env: test_env,
- protocol: 'tap',
+ protocol: test_protocol,
suite: suites,
timeout: timeout,
)