summaryrefslogtreecommitdiff
path: root/test/meson.build
diff options
context:
space:
mode:
authorSimon McVittie <smcv@collabora.com>2022-06-24 13:00:28 +0100
committerSimon McVittie <smcv@collabora.com>2022-07-13 20:36:13 +0100
commitc8ecf552c8cce8219912918a625bc6346d470a71 (patch)
tree5be9f974f532e6ee7b08a8b1989f75c3c3c970f7 /test/meson.build
parentfad7a62c39656de6cdf923ab37cfbb9dbe9be9ce (diff)
downloaddbus-c8ecf552c8cce8219912918a625bc6346d470a71.tar.gz
test: Allow for scripts that don't get installed
At the moment there aren't any like this, but it seems reasonable that we might get some later. Signed-off-by: Simon McVittie <smcv@collabora.com>
Diffstat (limited to 'test/meson.build')
-rw-r--r--test/meson.build3
1 files changed, 2 insertions, 1 deletions
diff --git a/test/meson.build b/test/meson.build
index 78755642..fa2338cc 100644
--- a/test/meson.build
+++ b/test/meson.build
@@ -566,8 +566,9 @@ endif
foreach script: scripts
name = script.get('name')
exec = script.get('exec', script.get('name'))
+ install = script.get('install', true)
- if install_tests
+ if install_tests and install
install_data(exec,
install_mode: 'rwxr-xr-x',
install_dir: test_exec_dir,