summaryrefslogtreecommitdiff
path: root/tools/CMakeLists.txt
diff options
context:
space:
mode:
authorRalf Habacker <ralf.habacker@freenet.de>2020-02-19 10:23:01 +0100
committerRalf Habacker <ralf.habacker@freenet.de>2020-02-19 10:23:01 +0100
commit2d256d42ce21b7b628887436eab44c8ef8c2f475 (patch)
treeda62dc9acfedfbf77af783a61fe385bd99b8d76e /tools/CMakeLists.txt
parentbfad7898cc59351f023a86ec0d7db8809c867438 (diff)
downloaddbus-2d256d42ce21b7b628887436eab44c8ef8c2f475.tar.gz
cmake: complete adding version info to all installed executables on Windows
Diffstat (limited to 'tools/CMakeLists.txt')
-rw-r--r--tools/CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/tools/CMakeLists.txt b/tools/CMakeLists.txt
index 1a5a5709..21efa98f 100644
--- a/tools/CMakeLists.txt
+++ b/tools/CMakeLists.txt
@@ -97,13 +97,17 @@ endif()
install(TARGETS dbus-launch ${INSTALL_TARGETS_DEFAULT_ARGS})
if(WIN32)
- add_executable_version_info(dbus_launch_SOURCES "dbus-monitor")
+ add_executable_version_info(dbus_monitor_SOURCES "dbus-monitor")
endif()
add_executable(dbus-monitor ${dbus_monitor_SOURCES})
target_link_libraries(dbus-monitor ${DBUS_LIBRARIES})
install(TARGETS dbus-monitor ${INSTALL_TARGETS_DEFAULT_ARGS})
+if(WIN32)
+ add_executable_version_info(dbus_run_session_SOURCES "dbus-run-session")
+endif()
+
add_executable(dbus-run-session ${dbus_run_session_SOURCES})
target_link_libraries(dbus-run-session ${DBUS_INTERNAL_LIBRARIES})
install(TARGETS dbus-run-session ${INSTALL_TARGETS_DEFAULT_ARGS})