summaryrefslogtreecommitdiff
path: root/tools/Makefile.am
diff options
context:
space:
mode:
authorRalf Habacker <ralf.habacker@freenet.de>2017-09-26 12:06:10 +0200
committerRalf Habacker <ralf.habacker@freenet.de>2017-09-27 22:05:13 +0200
commit214fbc6dbfa3547e8cf250c1dd41f1990d98e823 (patch)
treedf839fb04c27630a6988ad6092023e30ce049f49 /tools/Makefile.am
parentc6e79f9113d320679d3c29f83b306cb6e5d81bee (diff)
downloaddbus-214fbc6dbfa3547e8cf250c1dd41f1990d98e823.tar.gz
Add Windows manifest to dbus-update-activation-environment.exe
This explicitly sets the execution level to 'asInvoker', preventing Windows' UAC heuristics from deciding that because its name mentions "update", it probably needs to escalate privileges. Bug: https://bugs.freedesktop.org/show_bug.cgi?id=102558 Reviewed-by: Simon McVittie <smcv@collabora.com>
Diffstat (limited to 'tools/Makefile.am')
-rw-r--r--tools/Makefile.am17
1 files changed, 15 insertions, 2 deletions
diff --git a/tools/Makefile.am b/tools/Makefile.am
index 19aaf363..96ce03fa 100644
--- a/tools/Makefile.am
+++ b/tools/Makefile.am
@@ -114,9 +114,22 @@ dbus_update_activation_environment_SOURCES = \
$(NULL)
dbus_update_activation_environment_LDADD = $(top_builddir)/dbus/libdbus-1.la
-EXTRA_DIST = run-with-tmp-session-bus.sh strtoll.c strtoull.c
+if DBUS_WIN
+SUFFIXES = .rc
+
+.rc.o:
+ $(WINDRES) $< -o $@
+
+nodist_dbus_update_activation_environment_SOURCES = disable-uac.rc
+
+disable-uac.rc: Win32.Manifest
+ echo -e "1 24 \"$<\"" > $@
+endif
+
+EXTRA_DIST = run-with-tmp-session-bus.sh strtoll.c strtoull.c Win32.Manifest
CLEANFILES = \
- run-with-tmp-session-bus.conf
+ run-with-tmp-session-bus.conf \
+ $(nodist_dbus_update_activation_environment_SOURCES)
# create the /var/lib/dbus directory for dbus-uuidgen
install-data-local: