summaryrefslogtreecommitdiff
path: root/tools/Makefile.am
diff options
context:
space:
mode:
authorSimon McVittie <simon.mcvittie@collabora.co.uk>2015-02-11 15:47:53 +0000
committerSimon McVittie <simon.mcvittie@collabora.co.uk>2015-02-24 11:15:52 +0000
commit2a6cefbc3bd3ed9392603da6a76b49c0dcba7e0d (patch)
treedf99c280c45338a93752ba68c8cf90d3126e823a /tools/Makefile.am
parent263aca37ecf5f977f68d87b54f2fb30584725781 (diff)
downloaddbus-2a6cefbc3bd3ed9392603da6a76b49c0dcba7e0d.tar.gz
Add dbus-update-activation-environment tool
If OS builders (distributions) have chosen to use the per-user bus, this provides two possible modes of operation for compatibility with existing X session startup hooks. A legacy-free system can just upload DISPLAY, XAUTHORITY and possibly DBUS_SESSION_BUS_ADDRESS into dbus-daemon's and systemd's activation environments, similar to http://cgit.freedesktop.org/systemd/systemd/tree/xorg/50-systemd-user.sh installed by systemd (but unlike systemctl, dbus-update-activation-environment works for traditional D-Bus-activated services, not just for systemd services). A system where compatibility is required for environment variables exported by snippets in /etc/X11/xinit/xinitrc.d (in Red Hat derivatives, Gentoo, etc.) or /etc/X11/Xsession.d (Debian derivatives) can upload the entire environment of the X session, minus some selected environment variables which are specific to a login session (notably XDG_SESSION_ID). In Debian, I plan to put the former in a new dbus-user-session package that enables a user-session-centric mode of operation for D-Bus, and the latter in the existing dbus-x11 package, with the intention that dbus-x11 eventually becomes a tool for change-averse setups or goes away entirely. Bug: https://bugs.freedesktop.org/show_bug.cgi?id=61301 Reviewed-by: Philip Withnall <philip.withnall@collabora.co.uk>
Diffstat (limited to 'tools/Makefile.am')
-rw-r--r--tools/Makefile.am8
1 files changed, 8 insertions, 0 deletions
diff --git a/tools/Makefile.am b/tools/Makefile.am
index 80025b82..68a59707 100644
--- a/tools/Makefile.am
+++ b/tools/Makefile.am
@@ -16,6 +16,7 @@ bin_PROGRAMS = \
dbus-monitor \
dbus-send \
dbus-test-tool \
+ dbus-update-activation-environment \
$(NULL)
if DBUS_UNIX
@@ -98,6 +99,13 @@ dbus_test_tool_SOURCES = \
$(NULL)
dbus_test_tool_LDADD = $(top_builddir)/dbus/libdbus-1.la
+dbus_update_activation_environment_SOURCES = \
+ dbus-update-activation-environment.c \
+ tool-common.c \
+ tool-common.h \
+ $(NULL)
+dbus_update_activation_environment_LDADD = $(top_builddir)/dbus/libdbus-1.la
+
EXTRA_DIST = run-with-tmp-session-bus.sh strtoll.c strtoull.c
CLEANFILES = \
run-with-tmp-session-bus.conf