summaryrefslogtreecommitdiff
path: root/tools/Makefile.am
diff options
context:
space:
mode:
authorRalf Habacker <ralf.habacker@freenet.de>2015-11-18 23:35:46 +0100
committerRalf Habacker <ralf.habacker@freenet.de>2018-10-25 18:24:04 +0000
commitb0c0652005ce6892dd359f1b098dbdec9fb7455f (patch)
tree0e006251d6f504bb013691349080aaa784af9ae7 /tools/Makefile.am
parentf7e9b8a7379ce28e68bf1bd57e6f8d30602b938d (diff)
downloaddbus-b0c0652005ce6892dd359f1b098dbdec9fb7455f.tar.gz
Add Windows implementation of dbus-run-session tool
Bug: https://gitlab.freedesktop.org/dbus/dbus/issues/135 Signed-off-by: Ralf Habacker <ralf.habacker@freenet.de> Reviewed-by: Simon McVittie <smcv@collabora.com>
Diffstat (limited to 'tools/Makefile.am')
-rw-r--r--tools/Makefile.am7
1 files changed, 4 insertions, 3 deletions
diff --git a/tools/Makefile.am b/tools/Makefile.am
index cfce4348..f3450030 100644
--- a/tools/Makefile.am
+++ b/tools/Makefile.am
@@ -16,6 +16,7 @@ AM_LDFLAGS = @R_DYNAMIC_LDFLAG@
bin_PROGRAMS = \
dbus-launch \
dbus-monitor \
+ dbus-run-session \
dbus-send \
dbus-test-tool \
dbus-update-activation-environment \
@@ -24,7 +25,6 @@ bin_PROGRAMS = \
if DBUS_UNIX
bin_PROGRAMS += \
dbus-cleanup-sockets \
- dbus-run-session \
dbus-uuidgen \
$(NULL)
endif
@@ -57,6 +57,8 @@ dbus_launch_SOURCES= \
tool-common.c \
tool-common.h \
$(NULL)
+endif
+
dbus_launch_CPPFLAGS = \
$(AM_CPPFLAGS) \
$(NULL)
@@ -69,9 +71,8 @@ dbus_run_session_SOURCES = \
dbus-run-session.c
dbus_run_session_LDADD = \
- $(top_builddir)/dbus/libdbus-1.la \
+ $(top_builddir)/dbus/libdbus-internal.la \
$(NULL)
-endif
dbus_cleanup_sockets_SOURCES= \
dbus-cleanup-sockets.c