summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 66590792..2eb4b52c 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -377,8 +377,8 @@ endif()
if(UNIX AND NOT DBUS_DISABLE_ASSERT)
# required for backtrace
- string(APPEND CMAKE_C_FLAGS_DEBUG " -Wl,--export-dynamic")
- string(APPEND CMAKE_CXX_FLAGS_DEBUG " -Wl,--export-dynamic")
+ string(APPEND CMAKE_SHARED_LINKER_FLAGS " -Wl,--export-dynamic")
+ string(APPEND CMAKE_EXE_LINKER_FLAGS " -Wl,--export-dynamic")
set(DBUS_BUILT_R_DYNAMIC 1)
endif()