summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 7 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index dc5d60d6..c18bb2d9 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -271,7 +271,13 @@ if(MSVC)
else()
set(WARNINGS "sign-compare")
set(WARNINGS_DISABLED "")
- set(WARNINGS_ERRORS "")
+ set(WARNINGS_ERRORS
+ missing-prototypes
+ strict-prototypes
+ declaration-after-statement
+ implicit-function-declaration
+ undef
+ )
endif()
generate_warning_cflags(WARNINGS_CFLAGS "${WARNINGS}" "${WARNINGS_DISABLED}" "${WARNINGS_ERRORS}")
set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} ${WARNINGS_CFLAGS}")