summaryrefslogtreecommitdiff
path: root/bus/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'bus/CMakeLists.txt')
-rw-r--r--bus/CMakeLists.txt15
1 files changed, 9 insertions, 6 deletions
diff --git a/bus/CMakeLists.txt b/bus/CMakeLists.txt
index a52c1bfb..26f07dd2 100644
--- a/bus/CMakeLists.txt
+++ b/bus/CMakeLists.txt
@@ -143,15 +143,18 @@ set(LAUNCH_HELPER_SOURCES
)
if(NOT WIN32)
+ # test-bus-system depends on this library
add_library(launch-helper-internal STATIC ${LAUNCH_HELPER_SOURCES})
target_link_libraries(launch-helper-internal ${DBUS_INTERNAL_LIBRARIES} ${EXPAT_LIBRARIES})
- add_executable(dbus-daemon-launch-helper activation-helper.c activation-helper-bin.c )
- target_link_libraries(dbus-daemon-launch-helper launch-helper-internal)
- install(TARGETS dbus-daemon-launch-helper RUNTIME DESTINATION ${CMAKE_INSTALL_LIBEXECDIR})
- # It is intended not to check here that uid is 0 - see https://gitlab.freedesktop.org/dbus/dbus/-/merge_requests/154#note_478876
- install(CODE "message(\"-- Note: Not installing \$ENV{DESTDIR}\${CMAKE_INSTALL_PREFIX}/${CMAKE_INSTALL_LIBEXECDIR}/dbus-daemon-launch-helper binary setuid!\")")
- install(CODE "message(\"-- Note: You'll need to manually set permissions to 'root:${DBUS_USER}' and permissions '4750'\")")
+ if(ENABLE_TRADITIONAL_ACTIVATION)
+ add_executable(dbus-daemon-launch-helper activation-helper.c activation-helper-bin.c )
+ target_link_libraries(dbus-daemon-launch-helper launch-helper-internal)
+ install(TARGETS dbus-daemon-launch-helper RUNTIME DESTINATION ${CMAKE_INSTALL_LIBEXECDIR})
+ # It is intended not to check here that uid is 0 - see https://gitlab.freedesktop.org/dbus/dbus/-/merge_requests/154#note_478876
+ install(CODE "message(\"-- Note: Not installing \$ENV{DESTDIR}\${CMAKE_INSTALL_PREFIX}/${CMAKE_INSTALL_LIBEXECDIR}/dbus-daemon-launch-helper binary setuid!\")")
+ install(CODE "message(\"-- Note: You'll need to manually set permissions to 'root:${DBUS_USER}' and permissions '4750'\")")
+ endif()
endif()
if(MSVC)