summaryrefslogtreecommitdiff
path: root/common/meson.build
diff options
context:
space:
mode:
authorDaniel Playfair Cal <daniel.playfair.cal@gmail.com>2020-01-06 12:29:12 +1100
committerDaniel Playfair Cal <daniel.playfair.cal@gmail.com>2020-12-19 12:39:35 +1100
commit658af7018a349eb925503f920a3c6b5a948b0cc1 (patch)
tree91c9ec8cc96d11a3cad6f4c595ef7ab3a112f9ac /common/meson.build
parentd23b3fddd62cf5310c7f8869663ddb1c54c192dc (diff)
downloaddconf-658af7018a349eb925503f920a3c6b5a948b0cc1.tar.gz
move dconf-gvdb-utils from service into common
Diffstat (limited to 'common/meson.build')
-rw-r--r--common/meson.build5
1 files changed, 3 insertions, 2 deletions
diff --git a/common/meson.build b/common/meson.build
index befa9bc..e736ea8 100644
--- a/common/meson.build
+++ b/common/meson.build
@@ -15,18 +15,19 @@ sources = files(
'dconf-changeset.c',
'dconf-error.c',
'dconf-paths.c',
+ 'dconf-gvdb-utils.c',
)
libdconf_common = static_library(
'dconf-common',
sources: sources,
include_directories: top_inc,
- dependencies: glib_dep,
+ dependencies: [glib_dep, libgvdb_dep],
c_args: dconf_c_args,
pic: true,
)
libdconf_common_dep = declare_dependency(
- dependencies: glib_dep,
+ dependencies: [glib_dep, libgvdb_dep],
link_with: libdconf_common,
)