summaryrefslogtreecommitdiff
path: root/common/meson.build
diff options
context:
space:
mode:
authorDaniel Playfair Cal <daniel.playfair.cal@gmail.com>2020-12-19 02:27:07 +0000
committerDaniel Playfair Cal <daniel.playfair.cal@gmail.com>2020-12-19 02:27:07 +0000
commit6e19dec8d57174f3928171e102c24102f2b61ead (patch)
treee74764e806eba70ab76d3fc69927758413e2b736 /common/meson.build
parent6f7f010b69326eac4e8ee6e0ea7275aaf3232c80 (diff)
parent5ed0724cd763cf79dcc8f6802a6aa093d635cac7 (diff)
downloaddconf-6e19dec8d57174f3928171e102c24102f2b61ead.tar.gz
Merge branch 'patch/engine-check' into 'master'
Engine: Do not emit optimistic change notifications unless the local value is different See merge request GNOME/dconf!2
Diffstat (limited to 'common/meson.build')
-rw-r--r--common/meson.build5
1 files changed, 3 insertions, 2 deletions
diff --git a/common/meson.build b/common/meson.build
index befa9bc..e736ea8 100644
--- a/common/meson.build
+++ b/common/meson.build
@@ -15,18 +15,19 @@ sources = files(
'dconf-changeset.c',
'dconf-error.c',
'dconf-paths.c',
+ 'dconf-gvdb-utils.c',
)
libdconf_common = static_library(
'dconf-common',
sources: sources,
include_directories: top_inc,
- dependencies: glib_dep,
+ dependencies: [glib_dep, libgvdb_dep],
c_args: dconf_c_args,
pic: true,
)
libdconf_common_dep = declare_dependency(
- dependencies: glib_dep,
+ dependencies: [glib_dep, libgvdb_dep],
link_with: libdconf_common,
)