summaryrefslogtreecommitdiff
path: root/common/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'common/meson.build')
-rw-r--r--common/meson.build10
1 files changed, 4 insertions, 6 deletions
diff --git a/common/meson.build b/common/meson.build
index 51eb939..00f27ad 100644
--- a/common/meson.build
+++ b/common/meson.build
@@ -8,21 +8,19 @@ headers = files(
install_headers(
headers,
- subdir: join_paths(meson.project_name(), 'common')
+ subdir: join_paths('dconf', 'common')
)
-name = meson.project_name() + '-common'
-
sources = files(
'dconf-changeset.c',
'dconf-error.c',
'dconf-paths.c'
)
-cflags = ['-DG_LOG_DOMAIN="@0@"'.format(meson.project_name())]
+cflags = ['-DG_LOG_DOMAIN="dconf"']
libdconf_common = static_library(
- name,
+ 'dconf-common',
sources: sources,
include_directories: top_inc,
dependencies: glib_dep,
@@ -38,7 +36,7 @@ libdconf_common_dep = declare_dependency(
cflags += cc.get_supported_arguments('-fvisibility=hidden')
libdconf_common_hidden = static_library(
- name + '-hidden',
+ 'dconf-common-hidden',
sources: sources,
include_directories: top_inc,
dependencies: glib_dep,