summaryrefslogtreecommitdiff
path: root/DevIL/configure.ac
diff options
context:
space:
mode:
authorMatěj Týč <bubla@users.sourceforge.net>2009-03-08 17:14:13 +0000
committerMatěj Týč <bubla@users.sourceforge.net>2009-03-08 17:14:13 +0000
commit61eac47311e084c06da35a1c1023f9721d3caa27 (patch)
treecb29d2d4a46640660c0c3686e114703a00508554 /DevIL/configure.ac
parent4fcb489911f12f93bb2da21b3cc8933c809c64b6 (diff)
downloaddevil-61eac47311e084c06da35a1c1023f9721d3caa27.tar.gz
bugfixes of the build system
Diffstat (limited to 'DevIL/configure.ac')
-rw-r--r--DevIL/configure.ac23
1 files changed, 20 insertions, 3 deletions
diff --git a/DevIL/configure.ac b/DevIL/configure.ac
index 2146400b..86917084 100644
--- a/DevIL/configure.ac
+++ b/DevIL/configure.ac
@@ -245,7 +245,7 @@ dnl
dnl Libraries development checking
dnl
AC_ARG_WITH([zlib],
- [AC_HELP_STRING([--with-zlib=[[yes/no]]],
+ [AC_HELP_STRING([--with-zlib[[=yes/no]]],
[Do wou want to use zlib?])],
[],
[enable_zlib="yes"])
@@ -326,8 +326,25 @@ TEST_FORMAT([wbmp], [WBMP], [WBMP (Wireless Application Protocol Bitmap) is a mo
TEST_FORMAT([wdp], [WDP], [WDP is Microsoft's successor to JPEG, able to store many different image types either lossy or losslessly, also known as HD Photo.])
TEST_FORMAT([xpm], [XPM], [XPM (X PixMap) is an ASCII-based image used in X Windows.])
-DEVIL_CHECK_LIBSQUISH
-DEVIL_CHECK_NVIDIA_TEXTOOLS
+dnl
+dnl Give users chance to disable check for these two libraries that can't be disabled
+dnl by any other means...
+dnl
+AC_ARG_WITH([libsquish],
+ [AS_HELP_STRING([--with-squish[[=yes/no]]],
+ [Do you want to use the squish library if possible? (enables HW accelerated DXT compression, default="yes")]) ],
+ [],
+ [with_libsquish="yes"])
+AS_IF([test "x$with_libsquish" = "xyes"],
+ [DEVIL_CHECK_LIBSQUISH])
+
+AC_ARG_WITH([nvtt],
+ [AS_HELP_STRING([--with-nvtt[[=yes/no]]],
+ [Do you want to use the Nvidia texture tools if possible? (enables GPU accelerated image manipulation, default="yes")]) ],
+ [],
+ [with_nvtt="yes"])
+AS_IF([test "x$with_nvtt" = "xyes"],
+ [DEVIL_CHECK_NVIDIA_TEXTOOLS])
dnl
dnl ILUT APIs library checking