summaryrefslogtreecommitdiff
path: root/DevIL/configure.ac
diff options
context:
space:
mode:
authorMatěj Týč <bubla@users.sourceforge.net>2008-12-18 21:08:59 +0000
committerMatěj Týč <bubla@users.sourceforge.net>2008-12-18 21:08:59 +0000
commite13242d5547c0bd3198331ba7a51b1f1f218c5ed (patch)
tree8a023e96ec6eed482676ebd36fc7a610d32c9d3d /DevIL/configure.ac
parentc538c2f7f7ed08d1609408429922468e20c76ff9 (diff)
downloaddevil-e13242d5547c0bd3198331ba7a51b1f1f218c5ed.tar.gz
added missing directory in examples and tuned opengl detection during configure phase
Diffstat (limited to 'DevIL/configure.ac')
-rw-r--r--DevIL/configure.ac11
1 files changed, 9 insertions, 2 deletions
diff --git a/DevIL/configure.ac b/DevIL/configure.ac
index a0228ee0..8c6a357f 100644
--- a/DevIL/configure.ac
+++ b/DevIL/configure.ac
@@ -81,7 +81,7 @@ dnl
SUPPORTED_FORMATS=""
SUPPORTED_API=""
SUPPORTED_EXTENSION=""
-AC_REVISION([$Revision: 1.42 $])
+AC_REVISION([$Revision: 1.43 $])
dnl AC_PREFIX_DEFAULT(/usr/local)
AC_CANONICAL_HOST
dnl AC_LANG([C++])
@@ -183,7 +183,11 @@ AS_IF([test "x$enable_asm" = "xyes"],
TEST_ASM([powerpc*],
[PPC_ASM],
[GCC_PCC_ASM],
- [ppc]) ])
+ [ppc])
+ AS_IF([test -n "$SUPPORTED_EXTENSION"],
+ [AC_DEFINE([IL_INLINE_ASM],
+ [1],
+ [Define if you can support at least some ASM]) ]) ])
dnl
dnl Test warning build options
@@ -301,6 +305,9 @@ AM_CONDITIONAL([USE_DIRECTX],
AM_CONDITIONAL([USE_OPENGL],
[test "x$use_ogl" = "xyes"])
+AM_CONDITIONAL([HAVE_GLUT],
+ [test "x$have_glut" = "xyes"])
+
AM_CONDITIONAL([USE_SDL],
[test "x$use_sdl" = "xyes"])