summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorcsilvers <csilvers@01de4be4-8c4a-0410-9132-4925637da917>2008-05-02 19:09:16 +0000
committercsilvers <csilvers@01de4be4-8c4a-0410-9132-4925637da917>2008-05-02 19:09:16 +0000
commitd7f635ce8d07d1031c338e38ad03d8b8b62180a2 (patch)
tree5d460bb81a7476b2189f7d39971856b8bb13162d /configure.ac
parentd32295145ecde47354912cfe65f466921f3bf2e1 (diff)
downloaddistcc-d7f635ce8d07d1031c338e38ad03d8b8b62180a2.tar.gz
For machines without python installed, before this change we'd check
for that case, but still give an error rc in that case, so the make would fail. Now I make sure we don't fail just because we don't have python installed. Also, some machines (solaris 10) don't have a grep with -q, so just use >/dev/null insteasd. Third, we had left out a file to add to the tarball: ontest.py. Fourth, 'make distcheck' fails a bit on the pump-installcheck. I've addressed some of the problems, but others remain. Finally -- and this is the bulk of the change, line-count wise, I added quotes around all variables, so we do the right thing when variables have spaces or other shell-meaningful characters in them, as indeed they often do on windows machines. Tested by running 'make check' on various architectures, including solaris 10 x86 and cygwin. Reviewed by klarlund@google.com and fergus@google.com git-svn-id: http://distcc.googlecode.com/svn/trunk@100 01de4be4-8c4a-0410-9132-4925637da917
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index abb2940..9e20584 100644
--- a/configure.ac
+++ b/configure.ac
@@ -218,13 +218,13 @@ AC_PROG_INSTALL
AC_PATH_PROGS(PYTHON, [python2.4 python-2.4 python])
AC_ARG_VAR(PYTHON, [Python interpreter])
# Python 1 doesn't even support -V
-if ! "$PYTHON" -V 2>&1 | grep -q "^Python"; then
+if ! "$PYTHON" -V 2>&1 | grep "^Python" >/dev/null; then
TEST_PYTHON=""
INCLUDESERVER_PYTHON=""
-elif "$PYTHON" -V 2>&1 | grep -q "^Python 2.1"; then
+elif "$PYTHON" -V 2>&1 | grep "^Python 2.1" >/dev/null; then
TEST_PYTHON=""
INCLUDESERVER_PYTHON=""
-elif "$PYTHON" -V 2>&1 | grep -q "^Python 2.[[23]]"; then
+elif "$PYTHON" -V 2>&1 | grep "^Python 2.[[23]]" >/dev/null; then
TEST_PYTHON="$PYTHON"
INCLUDESERVER_PYTHON=""
else