summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac22
1 files changed, 13 insertions, 9 deletions
diff --git a/configure.ac b/configure.ac
index 8b18122..feec478 100644
--- a/configure.ac
+++ b/configure.ac
@@ -359,17 +359,21 @@ else
POPT_INCLUDES=''
fi
-AC_CHECK_LIB([iberty], [expandargv],
- ,
- AC_MSG_ERROR([Cannot find libiberty]))
-AC_CHECK_HEADERS([libiberty.h libiberty/libiberty.h],
- [break])
-if (test "$ac_cv_header_libiberty_h" != yes) &&
- (test "$ac_cv_header_libiberty_libiberty_h" != yes); then
- AC_MSG_ERROR([Cannot find libiberty.h])
+AC_ARG_WITH(binutils,
+ AC_HELP_STRING([--without-libiberty], [build without libiberty (no @file support)]))
+
+if test x"$with_libiberty" != xno; then
+ AC_CHECK_LIB([iberty], [expandargv],
+ ,
+ AC_MSG_ERROR([Cannot find libiberty]))
+ AC_CHECK_HEADERS([libiberty.h libiberty/libiberty.h],
+ [break])
+ if (test "$ac_cv_header_libiberty_h" != yes) &&
+ (test "$ac_cv_header_libiberty_libiberty_h" != yes); then
+ AC_MSG_ERROR([Cannot find libiberty.h])
+ fi
fi
-
########################################################################
# Check for types
AC_TYPE_SIGNAL