summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorRegis Merlino <regis.merlino@intel.com>2013-04-10 14:15:58 +0200
committerRegis Merlino <regis.merlino@intel.com>2013-04-10 14:15:58 +0200
commit329a2855eefeaeefe168de4ba80c896ea1421d6b (patch)
treef7190207387dedd44dd3de8dd2ae5a74adf3d49d /configure.ac
parent2022ea78c884e6b6488afcd3d409e81a531d06f1 (diff)
downloaddleyna-server-329a2855eefeaeefe168de4ba80c896ea1421d6b.tar.gz
[Configure] Check for the dbus connector lib availability if required
Signed-off-by: Regis Merlino <regis.merlino@intel.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 4 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 2c6cac8..1eb19aa 100644
--- a/configure.ac
+++ b/configure.ac
@@ -186,7 +186,6 @@ AC_ARG_WITH(ua-prefix,
[])
-
AC_ARG_ENABLE(lib-only,
AS_HELP_STRING(
[--enable-lib-only],
@@ -194,15 +193,16 @@ AC_ARG_ENABLE(lib-only,
[],
[enable_lib_only=no])
-AS_IF([test "x$[]enable_lib_only" = "xno"],
+AS_IF([test "x$enable_lib_only" = "xno"],
[PKG_CHECK_MODULES([DBUS], [dbus-1],
[DBUS_SESSION_DIR=`$PKG_CONFIG --variable=session_bus_services_dir dbus-1`;
AC_SUBST(DBUS_SESSION_DIR)
],
- [enable_lib_only=yes])
+ [enable_lib_only=yes]);
+ PKG_CHECK_MODULES([DLEYNA_CONNECTOR_DBUS], [dleyna-connector-dbus-1.0])
])
-AM_CONDITIONAL([BUILD_SERVER], [test "x$[]enable_lib_only" = "xno"])
+AM_CONDITIONAL([BUILD_SERVER], [test "x$enable_lib_only" = "xno"])
AC_DEFINE([DLEYNA_SERVER_OBJECT], "/com/intel/dLeynaServer", [Name of object exposed by dleyna-server])
AC_DEFINE([DLEYNA_SERVER_PATH], "/com/intel/dLeynaServer/server", [Path of server objects])