summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorRegis Merlino <regis.merlino@intel.com>2013-02-26 17:17:06 +0100
committerRegis Merlino <regis.merlino@intel.com>2013-02-26 17:17:06 +0100
commita6ba856815a40ee38a558791222976e952bf1c17 (patch)
treec8f97c1a8d4f4c6bc28088408ac43d32521868e8 /configure.ac
parentf369405a287c80236402ff951d96bf55c6703465 (diff)
downloaddleyna-server-a6ba856815a40ee38a558791222976e952bf1c17.tar.gz
[Build] Enable SOUP session User Agent Customization
- Add the optional --with-ua-prefix flag to allow the customization of the SOUP session User Agent Customization at build configuration time. - Construct our user agent prefix with the following template: %s dLeyna/%VERSION %s is the value provided --with-ua-prefix if any %VERSION is the dLeyna version - Call g_set_prgname(...) API to make our ua-prefix usable by libsoup. Example: with ./bootstrap-configure --with-ua-prefix=MypProject user agent value will be: MyProject dLeyna/0.0.1 GUPnP/0.19.4 DLNADOC/1.50 if ./bootstrap-configure is called without --with-ua-prefix, user agent value will be: dLeyna/0.0.1 GUPnP/0.19.4 DLNADOC/1.50 This is a port of commit https://github.com/01org/media-service-upnp/commit/22c051228d484392a42803e3e841819ea8789782 Signed-off-by: Regis Merlino <regis.merlino@intel.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 08ec2be..acaaae0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -168,6 +168,15 @@ AC_ARG_WITH(log-type,
DLEYNA_LOG_TYPE_CHECK([${with_log_type}])
+AC_ARG_WITH(ua-prefix,
+ AS_HELP_STRING(
+ [--with-ua-prefix],
+ [Specify a user agent prefix]),
+ [with_ua_prefix = "$withval"; AC_DEFINE_UNQUOTED([UA_PREFIX], "$with_ua_prefix", [User Agent prefix])],
+ [])
+
+
+
AC_ARG_ENABLE(lib-only,
AS_HELP_STRING(
[--enable-lib-only],
@@ -236,6 +245,7 @@ CFLAGS : '${CFLAGS}'
- disable-optimization: ${disable_optimization}
- with-log-level : ${with_log_level}
- with-log-type : ${with_log_type}
+ - with-ua-prefix : ${with_ua_prefix}
- enable-lib-only : ${enable_lib_only}
--------------------------------------------------"])