summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorSimon Kelley <simon@thekelleys.org.uk>2014-01-28 11:08:57 +0000
committerSimon Kelley <simon@thekelleys.org.uk>2014-01-28 11:08:57 +0000
commit00ec693db886dac7eb545fbafbb9f81d1fadbd00 (patch)
treecd6a1da790ec2a57ad451408311fe45348eee194 /debian/rules
parent70b4a818efbe084c3ab8711ad46f1d1da6d0d110 (diff)
downloaddnsmasq-00ec693db886dac7eb545fbafbb9f81d1fadbd00.tar.gz
Debian package with DNSSEC now possible.
DNSSEC will eventually become opt-out and when that happens I'll add libnettle build-depends. For now, build with fakeroot debian/rules DEB_BUILD_OPTIONS=usednssec to get DNSSEC support.
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules6
1 files changed, 5 insertions, 1 deletions
diff --git a/debian/rules b/debian/rules
index 7b9f4da..abb9bc0 100755
--- a/debian/rules
+++ b/debian/rules
@@ -17,7 +17,7 @@ CFLAGS += -Wall -W
LDFLAGS = $(shell dpkg-buildflags --get LDFLAGS)
-COPTS =
+COPTS =
TARGET = install-i18n
@@ -77,6 +77,10 @@ ifneq (,$(filter uselua,$(DEB_BUILD_OPTIONS)))
COPTS += -DHAVE_LUASCRIPT
endif
+ifneq (,$(filter usednssec,$(DEB_BUILD_OPTIONS)))
+ COPTS += -DHAVE_DNSSEC
+endif
+
clean:
$(checkdir)
rm -rf debian/daemon debian/base debian/utils debian/*~ debian/files debian/substvars debian/utils-substvars