summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorSimon Kelley <simon@thekelleys.org.uk>2012-02-11 22:14:52 +0000
committerSimon Kelley <simon@thekelleys.org.uk>2012-02-11 22:14:52 +0000
commit127ea40ae7ae9a549212a52e0175beb33b25f627 (patch)
treec4b004f4604374ccb60ba34af08c78716700087a /debian/rules
parent6aef600d481ceb6fc5ef9482a7932d60efdcf11f (diff)
downloaddnsmasq-127ea40ae7ae9a549212a52e0175beb33b25f627.tar.gz
Don't build DHCPv6 by default, except when build Debian package.
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules8
1 files changed, 4 insertions, 4 deletions
diff --git a/debian/rules b/debian/rules
index 6416ba9..08a9b1c 100755
--- a/debian/rules
+++ b/debian/rules
@@ -33,6 +33,10 @@ ifeq ($(DEB_BUILD_ARCH_OS),linux)
endif
endif
+ifeq (,$(filter nodhcp6,$(DEB_BUILD_OPTIONS)))
+ COPTS += -DHAVE_DHCP6
+endif
+
ifneq (,$(filter noipv6,$(DEB_BUILD_OPTIONS)))
COPTS += -DNO_IPV6
endif
@@ -45,10 +49,6 @@ ifneq (,$(filter nodhcp,$(DEB_BUILD_OPTIONS)))
COPTS += -DNO_DHCP
endif
-ifneq (,$(filter nodhcp6,$(DEB_BUILD_OPTIONS)))
- COPTS += -DNO_DHCP6
-endif
-
ifneq (,$(filter noscript,$(DEB_BUILD_OPTIONS)))
COPTS += -DNO_SCRIPT
endif