summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorSimon Kelley <simon@thekelleys.org.uk>2017-05-21 22:12:44 +0100
committerSimon Kelley <simon@thekelleys.org.uk>2017-05-21 22:12:44 +0100
commit43cdf1c3d074e75389392d495690923ef37d3248 (patch)
tree1da90d0084f3757889374013cea1521d0b289e72 /debian/rules
parentff19b1a97d377d36178eb1af92d1f411fa5c4348 (diff)
downloaddnsmasq-43cdf1c3d074e75389392d495690923ef37d3248.tar.gz
Remove automatic IDN support when building i18n.
Remove historic automatic inclusion of IDN support when building internationalisation support. This doesn't fit now there is a choice of IDN libraries. Be sure to include either -DHAVE_IDN or _DHAVE_LIBIDN2 for IDN support
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules7
1 files changed, 4 insertions, 3 deletions
diff --git a/debian/rules b/debian/rules
index fc0dcf4..2df656f 100755
--- a/debian/rules
+++ b/debian/rules
@@ -48,6 +48,10 @@ ifeq (,$(filter nodbus,$(DEB_BUILD_OPTIONS)))
DEB_COPTS += -DHAVE_DBUS
endif
+ifeq (,$(filter noidn, $(DEB_BUILD_OPTIONS)))
+ DEB_COPTS += -DHAVE_IDN
+endif
+
ifeq (,$(filter noconntrack,$(DEB_BUILD_OPTIONS)))
ifeq ($(DEB_HOST_ARCH_OS),linux)
DEB_COPTS += -DHAVE_CONNTRACK
@@ -84,9 +88,6 @@ endif
ifneq (,$(filter noi18n,$(DEB_BUILD_OPTIONS)))
TARGET = install
- ifeq (,$(filter noidn, $(DEB_BUILD_OPTIONS)))
- DEB_COPTS += -DHAVE_IDN
- endif
endif
ifneq (,$(filter uselua,$(DEB_BUILD_OPTIONS)))