summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorcyli <cyli@twistedmatrix.com>2017-04-13 17:25:55 -0700
committerJoffrey F <f.joffrey@gmail.com>2017-08-15 15:45:51 -0700
commit3b95da3ea48c3f60f133cdefe1382fce5d44a770 (patch)
tree702802ca7bf5a257027feb8125738a314841cd77 /setup.py
parent92a2e48e1740f9ecb055db6c960990483b4b349c (diff)
downloaddocker-py-3b95da3ea48c3f60f133cdefe1382fce5d44a770.tar.gz
Require "requests[security]" if the `[tls]` option is selected, which also installs:
pyOpenSSL, cryptography, idna and installs cryptography's version of openssl in Mac OS (which by default has an ancient version of openssl that doesn't support TLS 1.2). Signed-off-by: cyli <cyli@twistedmatrix.com>
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py10
1 files changed, 10 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 31180d2..534c949 100644
--- a/setup.py
+++ b/setup.py
@@ -35,6 +35,16 @@ extras_require = {
# ssl_match_hostname to verify hosts match with certificates via
# ServerAltname: https://pypi.python.org/pypi/backports.ssl_match_hostname
':python_version < "3.3"': 'ipaddress >= 1.0.16',
+
+ # If using docker-py over TLS, highly recommend this option is pip-installed
+ # or pinned.
+
+ # TODO: if pip installign both "requests" and "requests[security]", the
+ # extra package from the "security" option are not installed (see
+ # https://github.com/pypa/pip/issues/4391). Once that's fixed, instead of
+ # installing the extra dependencies, install the following instead:
+ # 'requests[security] >= 2.5.2, != 2.11.0, != 2.12.2'
+ 'tls': ['pyOpenSSL>=0.14', 'cryptography>=1.3.4', 'idna>=2.0.0'],
}
version = None