summaryrefslogtreecommitdiff
path: root/intel/meson.build
diff options
context:
space:
mode:
authorMatt Roper <matthew.d.roper@intel.com>2022-10-24 17:07:28 -0700
committerMatt Roper <matthew.d.roper@intel.com>2022-11-22 16:00:57 -0800
commit07dae1d10869f55412fa69db885edca58bedeef8 (patch)
tree62761d7e87c9e4530b5936b856892a3b8185069e /intel/meson.build
parente699b28b5494ab280f8b4e3ddbffd8ef4b7b7776 (diff)
downloaddrm-07dae1d10869f55412fa69db885edca58bedeef8.tar.gz
intel: Eliminate need to keep adding PCI IDs
The Intel-specific code in libdrm is continually updated with new PCI IDs for each new platform so that we can recognize the IP version properly. However this is mostly a pointless exercise; none of the Intel code in libdrm is conditional on IP versions above 8. If we just treat any future unrecognized Intel platforms as IP version 8, we should get the same behavior without the need for continued PCI ID updates. Note that the intel_decode tool probably _should_ have conditions on newer IP versions, but it was last updated for gen8 and has been bitrotting from gen9 onward. This change won't make the tool behave any more incorrectly than it already does today. Cc: Lucas De Marchi <lucas.demarchi@intel.com> Signed-off-by: Matt Roper <matthew.d.roper@intel.com>
Diffstat (limited to 'intel/meson.build')
-rw-r--r--intel/meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/intel/meson.build b/intel/meson.build
index e6550daa..beea42a6 100644
--- a/intel/meson.build
+++ b/intel/meson.build
@@ -23,7 +23,7 @@ libdrm_intel = library(
[
files(
'intel_bufmgr.c', 'intel_bufmgr_fake.c', 'intel_bufmgr_gem.c',
- 'intel_decode.c', 'mm.c', 'intel_chipset.c',
+ 'intel_decode.c', 'mm.c',
),
config_file,
],