summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMatt Johnston <matt@ucc.asn.au>2017-06-23 21:31:25 +0800
committerMatt Johnston <matt@ucc.asn.au>2017-06-23 21:31:25 +0800
commit0284717b49cbd9a58cf3237f6f4855f2d7b086e6 (patch)
treed9c015cd30d9deed81e10d06de9a14d1e4429303 /configure.ac
parent41006c069b65a01b92eb2f9a099ddd356047c5ac (diff)
downloaddropbear-0284717b49cbd9a58cf3237f6f4855f2d7b086e6.tar.gz
Compile with -fno-strict-overflow if possible.
Needed for curve25519-donna https://github.com/agl/curve25519-donna/issues/31
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 12 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 767bd05..1e4ea4a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -9,7 +9,7 @@ AC_PREREQ(2.59)
AC_INIT
AC_CONFIG_SRCDIR(buffer.c)
-OLDCFLAGS=$CFLAGS
+OLDCFLAGS="$CFLAGS"
# Checks for programs.
AC_PROG_CC
AC_PROG_MAKE_SET
@@ -24,6 +24,17 @@ if test -z "$OLDCFLAGS" && test "$GCC" = "yes"; then
CFLAGS="-Os -W -Wall -Wno-pointer-sign"
fi
+AC_MSG_CHECKING([if compiler '$CC' supports -fno-strict-overflow])
+OLDCFLAGS="$CFLAGS"
+CFLAGS="$CFLAGS -fno-strict-overflow"
+AC_COMPILE_IFELSE([AC_LANG_PROGRAM([])],
+ [AC_MSG_RESULT(yes)],
+ [
+ AC_MSG_RESULT(no)
+ CFLAGS=$OLDCFLAGS
+ ]
+ )
+
# large file support is useful for scp
AC_SYS_LARGEFILE